[Bug c++/28746] gcc -g and shared objects

jmbnyc at gmail dot com gcc-bugzilla@gcc.gnu.org
Wed Aug 16 02:48:00 GMT 2006



------- Comment #4 from jmbnyc at gmail dot com  2006-08-16 02:48 -------
Subject: Re:  gcc -g and shared objects

Just because it works for you does not mean it is not a problem. I am
not an idiot (and I am not saying that you implied that I was) and I
believe there is a problem. I believe the problem is not in ld, but in
the aspect of gcc that produces -g output. Perhaps I have something
screwed up with my system, but it is an unpatched default install of
RH FC5. I tried a regular c file and it worked fine with -g. So, it is
something with C++ compilation using -g.

/JMB

On 16 Aug 2006 02:36:27 -0000, pinskia at gcc dot gnu dot org
<gcc-bugzilla@gcc.gnu.org> wrote:
>
>
> ------- Comment #2 from pinskia at gcc dot gnu dot org  2006-08-16 02:36 -------
> This works for me and I really doubt this is a GCC issue anyways since GCC just
> outputs assembly which then gets into object code by binutils and binutils does
> the linking also.
>
>
> --
>
> pinskia at gcc dot gnu dot org changed:
>
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>              Status|UNCONFIRMED                 |RESOLVED
>          Resolution|                            |WORKSFORME
>
>
> http://gcc.gnu.org/bugzilla/show_bug.cgi?id=28746
>
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.
> You reported the bug, or are watching the reporter.
>


-- 


http://gcc.gnu.org/bugzilla/show_bug.cgi?id=28746



More information about the Gcc-bugs mailing list