[Bug c++/20628] New: QT has bugs when compiled with 4.0.0 but not 3.4.3

codemonkey49 at earthlink dot net gcc-bugzilla@gcc.gnu.org
Thu Mar 24 20:56:00 GMT 2005


I recently upgraded a gentoo to use 4.0.0 and recompiled all programs using it
(emerge -Due world) and some applications like psi and lincvs failed to work
properly afterwards.  They compiled and ran, but incorrectly.  Psi's password
dialog was not layed out properly and the user list did not populate.  Lincvs
went into an infinite loop.  I suspected that the problem was qt so I recompiled
just qt using 3.4.3 and the applications worked normally (the applications I
mentioned were still compiled with 4.0.0).

There were a few programs that did not recompile properly when converting to
4.0.0, but I am fairly sure they are not the cause of this bug because IIRC none
involved libraries.  In any case basically the whole system is compiled with
4.0.0-beta20050305.  I cannot isolate the exact problem due to the size and
compile time for qt.  Maybe qt is using non-standard C++ and so there is no bug
in gcc... but in any case I wanted to let you all know about it in case it's a
gcc bug.

-- 
           Summary: QT has bugs when compiled with 4.0.0 but not 3.4.3
           Product: gcc
           Version: 4.0.0
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: c++
        AssignedTo: unassigned at gcc dot gnu dot org
        ReportedBy: codemonkey49 at earthlink dot net
                CC: gcc-bugs at gcc dot gnu dot org
 GCC build triplet: 4.0.0
  GCC host triplet: 4.0.0_beta20050305
GCC target triplet: 4.0.0


http://gcc.gnu.org/bugzilla/show_bug.cgi?id=20628



More information about the Gcc-bugs mailing list