[Bug c++/20485] [3.4 Regression] ice with -O1 or above

pinskia at gcc dot gnu dot org gcc-bugzilla@gcc.gnu.org
Tue Mar 15 17:08:00 GMT 2005


------- Additional Comments From pinskia at gcc dot gnu dot org  2005-03-15 17:07 -------
Note this code is partly invalid (and will be rejected in 4.0) but fixing that invalidness, still gets the error 
in 3.4.x.  Basically friend support in 4.0 and above is closer to what the standard says it should be.

-- 
           What    |Removed                     |Added
----------------------------------------------------------------------------
           Keywords|                            |ice-on-valid-code
            Summary|ice with -O1 or above       |[3.4 Regression] ice with -
                   |                            |O1 or above
   Target Milestone|---                         |3.4.4


http://gcc.gnu.org/bugzilla/show_bug.cgi?id=20485



More information about the Gcc-bugs mailing list