[Bug middle-end/14311] builtins for atomic operations needed

bkoz at redhat dot com gcc-bugzilla@gcc.gnu.org
Mon Apr 11 17:14:00 GMT 2005


------- Additional Comments From bkoz at redhat dot com  2005-04-11 17:14 -------
Subject: Re:  builtins for atomic operations needed


> I'm working on atomic builtins, but this will *not* resolve the problem of
> compiling for i386 and i486+.  Indeed, it could easily make it worse because
> you won't have the kind of control you did before wrt hiding these operations
> in out-of-line functions.

Hurray. I really think that the builtin solution is the right way
forward for everybody, design-wise. Thanks for doing this Richard.

Pre gcc-3.4, we had the same problem with i386/i486+ separation. 

I think, realistically, that i486 compilation should be a minimum
requirement for linux distros circa 2005. (If not i586.). Thus, the
solution I will be in favor of is eliminating i386 compatibility with
the version of the toolchain that first implements the atomic builtins.

For people that really want to support i386, they should use gcc-2.7 to gcc-3.4.

-benjamin


-- 


http://gcc.gnu.org/bugzilla/show_bug.cgi?id=14311



More information about the Gcc-bugs mailing list