java/io/natFile.cc:106: internal compiler error: verify_ssa failed.
Daniel Berlin
dberlin@dberlin.org
Sat Sep 11 12:02:00 GMT 2004
On Sat, 11 Sep 2004, Zdenek Dvorak wrote:
> Hello,
>
>>>> While you are around there, can you rename it to tree-loop-ivopts?
>>>>
>>>> (I have no idea why zdenek keeps naming switches in ways that are
>>>> completely different than how we've been naming them :P).
>>>
>>> since I do not like the convention.
>>
>> This is not a good reason.
>>
>> If you want to convert *all* the switches, do so.
>> If not, the new switches should be consistent with the old ones.
>>
>> Understand that I could care less whether it's -fivopts or -fivcanon. I
>> care that it's not consistent with the existing options.
>>
>> Being consistent in our interface to the user is important.
>> Simply because you don't like the existing convention doesn't mean you
>> should just start using your own.
>
> should not this remark apply to the first person creating a
> -ftree-anything switch?
Unlike what you are doing, this was actually discussed on the mailing
list.
If you look at the archives, you'll see there was a discussion about what
to name the tree optimization options.
> the older convention that there is no such convention and everyone just
> names the switches the way he likes :-).
Sigh.
>
> Zdenek
>
More information about the Gcc-bugs
mailing list