[Bug libstdc++/14493] No std::bad_alloc::what() const
pme at gcc dot gnu dot org
gcc-bugzilla@gcc.gnu.org
Thu Mar 11 07:35:00 GMT 2004
------- Additional Comments From pme at gcc dot gnu dot org 2004-03-11 07:35 -------
> Honestly, is "std::bad_alloc" really that much more readable than
> "St9bad_alloc"?
The former is at least readable C++. More importantly, it's what 'new'
is documented as throwing, so a programmer reading (good) documentation
for operator new will see "std::bad_alloc".
> Especially compared to "bad allocation"?
Sure, we could change that. I don't think "bad allocation" is any
better than the demangled type name, but we shouldn't be printing
a mangled typeid. Others felt differently.
--
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=14493
More information about the Gcc-bugs
mailing list