target/9468: 3.2.1 not compiling under HP-UX 10.20 and 11.00 - gcc/varasm.c
Mon Jan 27 21:56:00 GMT 2003

>Number:         9468
>Category:       target
>Synopsis:       3.2.1 not compiling under HP-UX 10.20 and 11.00 - gcc/varasm.c
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    unassigned
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Jan 27 20:56:00 UTC 2003
>Originator:     Steve Baker
>Release:        3.2.1
HPUX 10.20 and 11.00. Compiling with gcc-3.2 (compiling with other versions of gcc produces the same error). binutils installed (installing with 2.13 produces the same error). Configure options: --prefix=/cm/tools/paks/gcc-3.2.1 --host=hppa1.1-hp-hpux10.20 --x-libraries=/usr/lib --x-includes=/usr/include/X11 --enable-languages=c,c++,java --with-dwarf2 --disable-multilib --enable-threads=single --enable-concept-checks --enable-clocale=generic --with-gnu-as --with-as=/cm/tools/paks/gcc-3.2.1/bin/as --with-gnu-ld --with-ld=/cm/tools/paks/gcc-3.2.1/bin/ld

(examples here show hp10.20)
After installing binutils, configuring gcc as shown above and running make, the following error results:

/cmbuild/public/TOOLS/gcc-3.2.1-build/gcc/xgcc -B/cmbuild/public/TOOLS/gcc-3.2.1-build/gcc/ -B/cm/tools/paks/gcc-3.2.1/hppa1.1-hp-hpux10.20/bin/ -B/cm/tools/paks/gcc-3.2.1/hppa1.1-hp-hpux10.20/lib/ -isystem /cm/tools/paks/gcc-3.2.1/hppa1.1-hp-hpux10.20/include -O2  -DIN_GCC    -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -isystem ./include  -fPIC -g  -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED  -I. -I. -I../../gcc-3.2.1/gcc -I../../gcc-3.2.1/gcc/. -I../../gcc-3.2.1/gcc/config -I../../gcc-3.2.1/gcc/../include  -DL_muldi3 -c ../../gcc-3.2.1/gcc/libgcc2.c -o libgcc/./_muldi3.o
../../gcc-3.2.1/gcc/libgcc2.c:0: Internal compiler error in default_no_named_section, at varasm.c:5305
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:> for instructions.
make[2]: *** [libgcc/./_muldi3.o] Error 1
make[2]: Leaving directory `/cmbuild/public/TOOLS/gcc-3.2.1-build/gcc'
make[1]: *** [libgcc.a] Error 2
make[1]: Leaving directory `/cmbuild/public/TOOLS/gcc-3.2.1-build/gcc'
make: *** [all-gcc] Error 2
Build gcc-3.2.1 as described above
None found so far. The error happens no matther what compiler I use to build 3.2.1. The only thing I have found the allows me to build without the error is to leave out binutils (and --with-gnu-as, --with-gnu-ld, etc) altogether. In this case, the compiler will build, and seems to work, except that there are as warnings about "--traditional-format" not being valid.

More information about the Gcc-bugs mailing list