other/9816: GCC 3.2.2 (Mingw Release candidate version) - Regression in building GNU Emacs 21.3 (CVS)

seagull@fastmail.fm seagull@fastmail.fm
Sun Feb 23 09:26:00 GMT 2003


>Number:         9816
>Category:       other
>Synopsis:       GCC 3.2.2 (Mingw Release candidate version) - Regression in building GNU Emacs 21.3 (CVS)
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    unassigned
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Feb 23 09:26:01 UTC 2003
>Closed-Date:
>Last-Modified:
>Originator:     seagull@fastmail.fm
>Release:        GCC-3.2.2 (MinGW32 version) on W2K
>Organization:
>Environment:
GCC 3.2.2 MingW GCC release candidate
Windows 2000
>Description:
- Compiling GNU Emacs 21.2.95 (Beta release) and 21.3 (CVS) is possible using GCC 3.2.1 Mingw on W2K
- The same fails using GCC 3.2.2 Mingw on W2K
It is a GCC regression (maybe a Mingw port regression)
>How-To-Repeat:
- Install MinGW 2.0 and add GCC 3.2.2 from (www.mingw.org)
- Download GNU Emacs 21.2.95 or 21.3 (from CVS)
- From emacs/nt, "configure --with-gcc" to use GCC
- "gmake bootstrap" for building GNU Emacs
- The executable gets built but while the built emacs.exe is used for compiling lisp files, it crashes on some.
>Fix:
- No fix
- I had to build using MSVC.
- Then rebuild with GCC
- Recompile all lisp files using the emacs.exe generated by MSVC (to avoid compilation of lisp files from GCC generated emacs.exe)
>Release-Note:
>Audit-Trail:
>Unformatted:



More information about the Gcc-bugs mailing list