new-RA problem bootstrapping mainline 3.2 on x86

Andreas Jaeger aj@suse.de
Sat Jul 20 11:46:00 GMT 2002


Graham Stott <graham.stott@btinternet.com> writes:

> Michael Matz wrote:
>> Hi Graham,
>> On Thu, 18 Jul 2002, Graham Stott wrote:
>>
>>>Attempting to bootstrap mainline 3.2 on i686-pc-linux-gnu with
>>>new_regalloc enabled by default fails building stage2 with this abort
>>>
>>>/gcc3.2/gcc/gcc/gengtype.c: In function `get_file_basename':
>>>/gcc3.2/gcc/gcc/gengtype.c:683: internal compiler error: Internal compiler error in check_colors, at ra-colorize.c:2045
>> You need to tell me exactly which options you used to configure.  I
>> used
>> just --enable-shared --enable-threads on i686-pc-linux-gnu but don't get a
>> problem.  Hmm, OTOH I used a two days old version of HEAD, maybe that's
>> the problem, I'll test again.
> Nothing special configure wise just --prefix=blah
>
> But note I did modify the initialization of flag_new_regalloc so that it defaults to 1.

I just tried the same on i686-linux-gnu with today's CVS and it worked
fine for me,

Andreas
-- 
 Andreas Jaeger
  SuSE Labs aj@suse.de
   private aj@arthur.inka.de
    http://www.suse.de/~aj



More information about the Gcc-bugs mailing list