GCC and header files of HP-UX11.11 don't cooperate

law@redhat.com law@redhat.com
Thu Feb 21 07:37:00 GMT 2002

In message <3C750EC6.7050307@tu-harburg.de>, Jan =?ISO-8859-1?Q?K=F6hnlein?= wr
 > Hi,
 > I have encountered problem compiling gcc on a HP Workstation (HP-UX, 
 > B.11.11 U 9000/785):
 > GCC did not compile because HPs sys/stdsyms.h defines
 >     #define __size_t size_t;
 > but doesn't define "size_t" itself. As an effect, gcc's stddef.h did not 
 > define it either, if sys/stdsyms.h was included before (e.g. in 
 > <arch>/libiberty/floatformat.c) and compilation stopped.
 > Changing gcc/ginclude/stddef.h for my specific system is not a big problem:
 > Make sure gcc's stddefs.h defines size_t by commenting out  #ifndef 
 > __size_t in line 180 and matching #endif. Then avoid redefinition of 
 > __size_t  in line 194.
 > Well, now it works, but I am not sure if other OS's wouldn't work with 
 > these changes. Maybe someone knows a safer way to achive this. If I am 
 > the only person affected, this might also be due to a buggy installation 
 > of our operating system. I have to admit, that I tried this on the 3.0.1 
 > code, but there haven't been any modifications of the involved parts 
 > since then.
Yes.  This is a known problem.  GCC releases prior to the upcoming GCC 3.1
release do not properly handle the hpux1.11 (aka hpux11i) header files.
[ It's also the case that they don't handle hpux11.00 with certain patchkits
  which make the header files have the characteristics as hpux11.11. ]


More information about the Gcc-bugs mailing list