Yves Dorfsman yves@zioup.com
Wed Sep 19 15:56:00 GMT 2001


I am not sure how usefull this will be to you. I am not sending this
expecting an answer, but more to point out a bug, and maybe help with gcc.

I was trying to compile ImageMagick with gcc 3.0.1, and got "Internal
compiler error". I tried to compile again with gcc 2.8.1, and it worked

The output from gcc is in the attached file "typescript". The .i file is
attached too. I really do not have time to try to pinpoint what exact
piece of the source cause this error, or to put a simple piece of code
that generate the error, but will try later. For information, I used the
ImageMagick 5.3.9 source straigth out of the tar ball with no

Here is the command that is run:

gcc -v -save-temps -DHAVE_CONFIG_H -I../ -I.. -I../magick -D_REENTRANT
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/global/include -g -O2
-Wall -c fits.c -Wp,-MD,.deps/fits.TPlo -o fits.o

Yves Dorfsman                                             yves@zioup.com

More information about the Gcc-bugs mailing list