Parsing bug in all recent versions

Stephen M.Webb stephenw@cryptocard.com
Thu Jul 19 11:53:00 GMT 2001


> It seems that all recent versions of gcc (2.95.2,
> 2.95.3, 3.0) on Solaris 7 and 8 appear to have the
> following bug: they accept any number of "::iterator"
> on some (maybe all) the STL iterators, e.g. all of
> these are accepted:
> 
> std::list<int>::iterator  p;
> std::list<int>::iterator::iterator  p;
> std::list<int>::iterator::iterator::iterator  p;

This isn't a parsing error in gcc but a coding problem in the
libstdc++ STL.  It's harmless but you should submit a problem report
through GNATS so it gets addressed.


_______
Stephen M. Webb



More information about the Gcc-bugs mailing list