3.1 Bootstrap failure on sparc-solaris2.8

Brad Lucier lucier@math.purdue.edu
Wed Jul 4 06:08:00 GMT 2001


> > The error is
> > 
> > __GCC_FLOAT_NOT_NEEDED  -I. -I. -I../../gcc -I../../gcc/. -I../../gcc/config -I../../gcc/../include  -DL_floatdisf -c ../../gcc/libgcc2.c -o libgcc/./_floatdisf.o
> > ../../gcc/libgcc2.c: In function `__floatdisf':
> > ../../gcc/libgcc2.c:1129: Internal compiler error in subreg_highpart_offset, at emit-rtl.c:1180
> 
> See http://gcc.gnu.org/ml/gcc-patches/2001-06/msg01619.html which fixes
> this and still hasn't been reviewed (just a shameless plug :-).

This patch no longer applies cleanly to the 3.1 tree; perhaps you
can update it and resubmit it.  My understanding is that patches
that fix bootstrap failures are given higher priority recently.

Brad



More information about the Gcc-bugs mailing list