gcc-bug ??

Andreas Jaeger aj@suse.de
Sun Apr 22 07:22:00 GMT 2001


Bernd Kuehbach <kuehbach@addcom.de> writes:

> Hello over there !
> 
> First of all: If this is the wrong way to report a bug, please send me a short message
> on how to do it correctly. It's the first time I'm using GNU software and I'm not yet 
> too familiar with your rules.
> 
>  
>  
> Now the problems:
> 
> On my ATHLON I tried to build gcc (2.95.2) under (SUSE-)linux. The "configure"
> went OK, but the "make bootstrap" issued the following error message  (after
> about 5 minutes of compiling happily and productively  :-) 

Are you running SuSE 7.1?  In that case you need gcc 2.95.3 or extra
patches for gcc (see the SuSE source rpm for what we ship) to work
with glibc 2.2.
[...]
> 
> I have the SU (seismic un*x, Colorado School of Mines) package installed
> on my machine (under SUSE-linux). No problems occured during the
> installation until I added my own stuff, which used to be running under SU
> on an IBM 320H workstation (under AIX 3.something).
> 
> I am calling FORTRAN from C several times, and everything works all
> right, but when there is eg exponentiation (a**B) within the FORTRAN
> routine, an error message like the one below occurs: 
> 
>  
> ....
> ....
> cd mystuff ; make
> make[2]: Entering directory `/home/bernd/su/src/su/mystuff'
> gcc -O   -I/home/bernd/su/include  dipmodel.c  -L/home/bernd/su/lib  -lsu -lpar -lF77 -lcwp -lm  -o /home/bernd/su/bin/dipmodel libftr.a
> 
> 
> /home/bernd/su/lib/libpar.a(subcalls.o): In function `etmpnam':
> subcalls.o(.text+0x3de): the use of `tmpnam' is dangerous, better use `mkstemp'
> libftr.a(genfilt.o): In function `genfilt_':
> genfilt.o(.text+0x50): undefined reference to `s_copy'

s_copy is part of libg2c.a:
$ nm /usr/lib/gcc-lib/i486-suse-linux/2.95.2/libg2c.a |grep copy
000000e0 t copy
         U s_copy
s_copy.o:
00000000 T s_copy
         U s_copy
         U s_copy
         U s_copy
         U s_copy
         U s_copy
         U s_copy
         U s_copy

The other functions that are missing are also part of libg2c, so you
should link against that library.
> So I thought there could be something wrong with gcc and/or g77
> under linux, and this is why tried to install gcc from scratch.

We don't break GCC on purpose ;-).

> Many thanks in anticipation of your help (and for all the great stuff
> your creating)

Andreas
-- 
 Andreas Jaeger
  SuSE Labs aj@suse.de
   private aj@arthur.inka.de
    http://www.suse.de/~aj



More information about the Gcc-bugs mailing list