f771 got fatal signal 11

KATAYAMA Jiro katayama@nesi.co.jp
Fri Apr 13 02:50:00 GMT 2001


g77 (Cygwin special?? see below) cannot compile following subroutine:

subroutine show_messages(iflg)
integer (kind=1) iflg

   select case(iflg)
     case(1)
        print *,'pass 1'
        print *,'pass 2'
        print *,'pass 3'
        print *,'pass 4'
        print *,'pass 5'
   end select
end

[>g77 -ffree-form -c test.f]

With only one PRINT statement, compiled successfully.
But with two PRINTs,  failed. (same error)
How about 3? No problem.
More than 4 PRINTSs, same error occurred.

By using older version of g77, such error does not occur.
Is this g77 problem? code problem? hardware problem?...

If there are some points I should check, please give me the
information.

Jiro.

-----------------------------------------------------------------------
[Windows2000 + service pack #1 / Dell Precision420]
**** older g77 ****
g77 version egcs-2.91.57 19980901 (egcs-1.1 release) (from FSF-g77 version 0.5.2
4-19980804)
gcc version egcs-2.91.57 19980901 (egcs-1.1 release)

**** Cygwin special ****
g77 version 2.95.3-1 (cygwin special) (from FSF-g77 version 0.5.25 20010315 (rel
ease))
Driving: g77 -v -c -xf77-version /dev/null -xnone
(...)
Reading specs from /usr/lib/gcc-lib/i686-pc-cygwin/2.95.3-1/specs
gcc driver version 2.95.3-1 (cygwin special) executing gcc version gcc-2.95.3-1
GNU CPP version 2.95.3-1 (cygwin special) (80386, BSD syntax)
(...)
GNU F77 version 2.95.3-1 (cygwin special) (i686-pc-cygwin) compiled by GNU C ver
sion gcc-2.95.3-1 (cygwin experimental).
GNU Fortran Front End version 0.5.25 20010315 (release)
(...)
__G77_LIBF77_VERSION__: 0.5.25 20010315 (release)
@(#)LIBF77 VERSION 19990503
__G77_LIBI77_VERSION__: 0.5.25 20010315 (release)
@(#) LIBI77 VERSION pjw,dmg-mods 19990503
__G77_LIBU77_VERSION__: 0.5.25 20010315 (release)
@(#) LIBU77 VERSION 19980709


More information about the Gcc-bugs mailing list