bootstrap failure i686-pc-linux-gnu

Alexandre Oliva aoliva@redhat.com
Mon Apr 2 22:40:00 GMT 2001


On Apr  3, 2001, Mark Mitchell <mark@codesourcery.com> wrote:

>>>>>> "Alan" == Alan Modra <alan@linuxcare.com.au> writes:
Alan> On Mon, 2 Apr 2001, Mark Mitchell wrote:

>>> Is it now necessary to have a CVS version of GAS to build the
>>> GCC 3.0 branch?

Alan> One version of the bug fix is in 2.11, rumoured to be
Alan> released this week.

> That is good.  In that case, we should just make the configure script
> abort if you don't have GAS 2.11 or greater.

It looks like you may have missed (or not yet got to) a message by
RTH, I think, in which he explains the problem: some relatively recent
snapshots of binutils seem to be broken support of `.uleb'.  If this
pseudo-op is not supported at all, or if it's already fixed,
everything works; only people who happen to have one of the broken
snapshots will have to up- or downgrade.  It's probably not worth
adding a test to configure to detect the brokenness, unless it's
something trivial to do.

-- 
Alexandre Oliva   Enjoy Guarana', see http://www.ic.unicamp.br/~oliva/
Red Hat GCC Developer                  aoliva@{cygnus.com, redhat.com}
CS PhD student at IC-Unicamp        oliva@{lsd.ic.unicamp.br, gnu.org}
Free Software Evangelist    *Please* write to mailing lists, not to me



More information about the Gcc-bugs mailing list