Silly branch compile failure, stage 1

Kaveh R. Ghazi
Mon Apr 2 19:57:00 GMT 2001

 > From: Neil Booth <>
 > Kaveh R. Ghazi wrote:-
 > > Well, *I* haven't done anything to suddenly break this, but someone
 > > else may have.  But I do believe what you are doing is exactly the
 > > type of action that isn't supposed to work.  My info may be out of
 > > date, and/or it may have worked by accident up until now.  I don't
 > > know.
 > I wasn't trying to cast aspersions :-)

I didn't mean it that way. :-)  I just meant that I wasn't aware on
anything that would have broken it all of a sudden.

 > I tried it from a separate directory, and still have precisely the
 > same problem.  This is with a clean checkout from branch.
 > However, I notice that the result of my "autoconf" and "autoheader"
 > do not match what is on
 > monkey:gcc{381}$ cvs diff configure
 > Index: configure
 > ===================================================================
 > RCS file: /cvs/gcc/gcc/gcc/configure,v
 > retrieving revision 1.488.2.10
 > diff -u -p -r1.488.2.10 configure
 > --- configure	2001/03/17 18:43:28	1.488.2.10
 > +++ configure	2001/04/02 21:07:22
 > @@ -1582,7 +1582,7 @@ esac
 >  # Find some useful tools
 > -for ac_prog in gawk mawk nawk awk
 > +for ac_prog in mawk gawk nawk awk
 >  do
 >  # Extract the first word of "$ac_prog", so it can be a program name with args.
 >  set dummy $ac_prog; ac_word=$2
 > monkey:gcc{382}$ autoconf --v
 > Autoconf version 2.13

This is harmless.  The official autoconf-2.13 lists mawk first, but
lots of linux distributions switched autoconf to prefer gawk first.
(As a gnu tool, autoconf preferring gawk is the right thing to do

 > Maybe something is wrong with my local version (which was upgraded
 > recently with apt-get).  It's odd that no-one else is seeing it; so I'll
 > wait for a while and see if it goes away or if anyone else complains.
 > The output built from a wholly separate directory is below, for the
 > curious.  It looks like it goes bad starting with the bcopy test.
 > Neil.

Yep, all your DECL checks are failing (probably for the same reason.)
I don't have any idea why you're special in this regard though.
Can you try figuring out which CVS patch triggers it?

Kaveh R. Ghazi			Engagement Manager / Project Services		Qwest Internet Solutions

More information about the Gcc-bugs mailing list