Integrated preprocessor patch - revised

Philipp Thomas pthomas@suse.de
Mon Sep 11 08:21:00 GMT 2000


* Zack Weinberg (zack@wolery.cumb.org) [20000907 01:08]:

> 	* c-parse.gperf, c-gperf.h: Delete.

But you forgot to delete c-gperf.h from po/POTFILES.in :( This only shows
when configuring with --enable-maintainer-mode, as only then gcc.pot will be
built.

Mark, seems to me like we really need two things to avoid something like
this:

  - require maintainers to *not* configure with --disable-nls
  - have a target in po/Makefile that checks the dependencies of
    gcc.pot (listed in po/POTFILES.in) but doesn't try to build it.

That way bootstrapping gcc wouldn't fail only for me and thus such errors
would be caught much earlier. If you agree, I'll try to come up with a patch
that tackles the second point.

Question is where or how this checking target should get called.
Suggestions?

Philipp

-- 
Philipp Thomas <pthomas@suse.de>
Development, SuSE GmbH, Schanzaecker Str. 10, D-90443 Nuremberg, Germany


More information about the Gcc-bugs mailing list