make bootstrap segfaults on current cvs head (i686-pc-linux-gnu)

Mike Coleman mcoleman2@kc.rr.com
Fri Oct 13 03:07:00 GMT 2000


I get a segfault when trying to build gcc from the current cvs head.  I tried
starting with two different gcc versions and got the same result, so I don't
think it's hardware.

--Mike


Here's config.status:
#!/bin/sh
# This file was generated automatically by configure.  Do not edit.
# This directory was configured as follows:
../gcc/configure --with-gcc-version-trigger=/usr/local/src/gcc/gcc/gcc/version.c --host=i686-pc-linux-gnu --prefix=/usr/local/src/gcc/install --enable-lagnuages=c++ --enable-threads --norecursion 
#  using "mt-frag"

and here's the last few lines of the compile output:

rm -rf libcpp.a
ar rc libcpp.a cpplib.o cpplex.o cppmacro.o cppexp.o cppfiles.o cpphash.o cpperror.o cppinit.o cppdefault.o cppoutput.o mkdeps.o prefix.o version.o mbchar.o 
if [ -f ranlib ] || [ -f /usr/bin/ranlib -o -f /bin/ranlib ] ; then ranlib libcpp.a ; else true ; fi
stage1/xgcc -Bstage1/ -B/usr/local/src/gcc/install/i686-pc-linux-gnu/bin/  -DIN_GCC    -O2 -g -O2 -W -Wall -Wtraditional -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -pedantic -Wno-long-long  -DHAVE_CONFIG_H  -o cpp0 cppmain.o \intl.o libcpp.a obstack.o        ../libiberty/libiberty.a
./xgcc -B./ -B/usr/local/src/gcc/install/i686-pc-linux-gnu/bin/ -isystem /usr/local/src/gcc/install/i686-pc-linux-gnu/include -dumpspecs > tmp-specs
mv tmp-specs specs
echo "int xxy_us_dummy;" >tmp-dum.c
./xgcc -B./ -B/usr/local/src/gcc/install/i686-pc-linux-gnu/bin/ -isystem /usr/local/src/gcc/install/i686-pc-linux-gnu/include -S tmp-dum.c
cc1: Internal error: Segmentation fault.
   Please submit a full bug report.
   See <URL: http://www.gnu.org/software/gcc/bugs.html > for instructions.
make[2]: *** [s-under] Error 1
make[2]: Leaving directory `/usr/local/src/gcc/obj/gcc'
make[1]: *** [stage_c] Error 2
make[1]: Leaving directory `/usr/local/src/gcc/obj/gcc'
make: *** [bootstrap] Error 2


More information about the Gcc-bugs mailing list