new fixinclude problem on HP-UX

Marco Franzen
Wed Mar 29 06:30:00 GMT 2000

A few hours earlier, I wrote:
> I will try a new bootstrap after removing the generated script.
> Unfortunately, that little old HP machine is extremely slow, the successful
> bootstrap of gcc-2.95.2 (with BOOT_CFLAGS='-g -O3') took 14 hours.
> So I can tell you only tomorrow unless it fails early.

Well, it did fail early, mostly due to a mistake of my own.
Just wanted to let you know how it could have worked anyway.

The failure was:
MAKE="gmake"; srcdir=`cd ./fixinc; pwd` ; \
export MAKE srcdir ; \
cd ./fixinc; /bin/sh ${srcdir}/ hppa1.1-hp-hpux10.20
constructing ../ for hppa1.1-hp-hpux10.20
gmake SHELL="/bin/sh" install
gmake[3]: Entering directory `/usr/gnu/src/egcs/egcs/gcc/fixinc'
cd . ; ./genfixes
/bin/sh: ./genfixes: Execute permission denied.
gmake[3]: *** [] Error 126
gmake[3]: Leaving directory `/usr/gnu/src/egcs/egcs/gcc/fixinc'
Could not install binary fixincludes.
Installing shell script instead.
rm -rf incl
TARGET_MACHINE=hppa1.1-hp-hpux10.20; srcdir=`cd .; pwd`; \
INSTALL_ASSERT_H=install-assert-h; SHELL=/bin/sh ;\
/bin/sh ./ `pwd`/include /usr/include 
Fixing headers into /usr/gnu/src/egcs/egcs/gcc/include for hppa1.1-hp-hpux10.20 
Finding directories and links to directories
 Searching /usr/include/.
Making symbolic directory links
Fixing directory /usr/include into /usr/gnu/src/egcs/egcs/gcc/include
Checking header files
./[2004]: /usr/gnu/src/egcs/egcs/gcc/fixinc/fixtests:  not found.
./[2004]: /usr/gnu/src/egcs/egcs/gcc/fixinc/fixtests:  not found.
with the last line repeated a huge number of times. (It continued
bootstrapping blissfully anyway, and it might even have worked. But I
interrupted it to get the intended result rather than a random one that might
only happen to work.)

In gcc/fixinc/Makefile, there a two different styles being used for calling
genfixes, one calling it directly, as in
	fixincl.x: fixincl.tpl inclhack.def
	        cd $(srcdir) ; ./genfixes $@
the other one explicitly using a shell, in
	machname.h: ../specs
	        $(SHELL) $(srcdir)/genfixes $@
Using the latter style consequently would have prevented my failure to set the
execute permission from having an effect.

[The missing execution permission is probably a result of doing the anonymous
cvs on a WhimDoze box (which I don't control). My preferred Un*x boxes have no
connection to the public internet other than via a mail (store-and-forward)


-- Marco
{please ignore any confidentially clause that might be appended after this line}
This email is confidential and intended solely for the use of the
individual to whom it is addressed.
Any views or opinions presented are solely those of the author
and do not necessarily represent those of Thyron Limited.
If you are not the intended recipient then please be advised
that you have received this email in error and that any use,
dissemination, forwarding, printing or copying of this email
is strictly prohibited.
If you have received this email in error, please notify the
Thyron IT Administrator on +44 (0)1923 236 050 or
send an email to
Thank You

More information about the Gcc-bugs mailing list