gcc 2.95.2 / binutils / shared libraries problem

Dragos Harabor dharabor@us.oracle.com
Thu Jun 1 23:35:00 GMT 2000

Hello All,

I would appreciate if anybody has any suggestions for the following
problem. Please reply to me directly as I am not on the mailing lists yet.

Platform: Solaris 2.6 (latest patches)
gcc: 2.95.2
ld & as: (from binutils

I tried upgrading to gcc 2.95.2 and I compiled it using the ld and as
specified above. The compilation went fine. The problem is that whatever
shared objects gcc generates when I try to compile other packages they
seem to be corrupted, e.g. I tried Apache 1.3.12, the compile went fine
but I get the following error when trying to run it:

> Syntax error on line 207 of /home/dharabor/tmp/apache/conf/httpd.conf:
> Cannot load /home/dharabor/tmp/apache/libexec/mod_env.so into
> server: ld.so.1: /home/dharabor/tmp/apache/bin/httpd: fatal: relocation
> error: file /home/dharabor/tmp/apache/libexec/mod_env.so: symbol
> ap_palloc: referenced symbol not found
> ./apachectl start: httpd could not be started

Here are more facts:

* I tried binutils- with a 2.95.2 version of gcc that was built
on a different system by somebody else. It looks like ld works fine in
building the Apache shared libraries as I was able to run that version.

* I am trying to build gcc for an NFS server, so it is not an option to
get a precompiled package due to paths problems (is there a way to fix the

* Please see the attached files for the options that I compiled the
packages with.

Any help is highly appreciated.



More information about the Gcc-bugs mailing list