Installation bug for AIX 4.3.2

Gregory Hicks
Sat Jan 15 15:42:00 GMT 2000

Geoff (Or whomever is available to help with this):

Greetings.  Finally got a make (from previous version of gcc) and make
install (of 2.95.2) to run on the machine.  Setting the
"LDFLAGS=-Wl,-bbigtoc" worked like a champ!  Thanks!

I then tried to use the just installed 2.95.2 verison to compile the
2.95.2 that was to be mounted in the final directory
(/usr/ngnu/gcc-2.95.2).  The compile worked.  The "make install" did
not.  The error message returned is as follows:

>creating cache ./config.cache
>checking if compiler f771 has been built... yes
>checking for gcc... /gnuwork/gcc/gcc-2.95.2/gcc/xgcc -B/gnuwork/gcc/gcc-2.95.2/gcc/ -B/tmp/gcc-2.95.2/rs6000-ibm-aix4.3.2.0/bin/
>checking whether the C compiler (/gnuwork/gcc/gcc-2.95.2/gcc/xgcc -B/gnuwork/gcc/gcc-2.95.2/gcc/ -B/tmp/gcc-2.95.2/rs6000-ibm-aix4.3.2.0/bin/ -g -O2 ) works... yes
>checking whether the C compiler (/gnuwork/gcc/gcc-2.95.2/gcc/xgcc -B/gnuwork/gcc/gcc-2.95.2/gcc/ -B/tmp/gcc-2.95.2/rs6000-ibm-aix4.3.2.0/bin/ -g -O2 ) is a cross-compiler... no
>checking whether we are using GNU C... yes
>checking whether /gnuwork/gcc/gcc-2.95.2/gcc/xgcc -B/gnuwork/gcc/gcc-2.95.2/gcc/ -B/tmp/gcc-2.95.2/rs6000-ibm-aix4.3.2.0/bin/ accepts -g... yes
>checking for a BSD compatible install... ../../../install-sh -c
>checking whether make sets ${MAKE}... yes
>checking how to run the C preprocessor... /gnuwork/gcc/gcc-2.95.2/gcc/xgcc -B/gnuwork/gcc/gcc-2.95.2/gcc/ -B/tmp/gcc-2.95.2/rs6000-ibm-aix4.3.2.0/bin/ -E
>checking for stdio.h... yes
>checking f2c integer type... long int
>checking f2c long int type... long long int
>checking host system type... rs6000-ibm-aix4.3.2.0
>checking target system type... rs6000-ibm-aix4.3.2.0
>checking build system type... rs6000-ibm-aix4.3.2.0
>updating cache ./config.cache
>creating ./config.status
>creating Makefile
>creating g2c.h
>Adding multilib support to Makefile in .
>configuring in libU77
>running /bin/sh ../../../configure  --with-multisubdir=soft-float --with-multisrctop=../ --enable-multilib --host=rs6000-ibm-aix4.3.2.0 --build=rs6000-ibm-aix4.3.2.0 --enable-multilib --with-gcc-version-trigger=/gnuwork/gcc/gcc-2.95.2/gcc/version.c --prefix=/usr/ngnu/gcc-2.95.2 --with-target-subdir=rs6000-ibm-aix4.3.2.0 --cache-file=.././config.cache --srcdir=.
>/bin/sh: ../../../configure:  not found
>configure: error: ../../../configure failed for libU77
>make: 1254-004 The error code from the last command is 1.
># pwd

Any further thoughts?

Thanks in advance!

Gregory Hicks

> From: Geoff Keating <>
> Date: 14 Jan 2000 21:43:02 -0800
> Gregory Hicks <> writes:
> > I give up.  I need some help.  I've run across this error each time I
> > compile gcc-2.95.2 with gcc-2.95.2.  Can provide a pointer or two on
> > how to fix?  I've tried on 9 different AIX boxes so far.
> > 
> > AIX in question is version 4.3.2
> > 
> > CC=gcc (/gnuworks/gcc-2.95.2.obj/bin/gcc)
> > $TEMP=/gnuworks (1.4GB+ available)
> > $TMP=/gnuworks
> > 
> > (I used the two above because the IBM person I talked to wasn't sure
> > which one to use...)
> > 
> > Any assist would be appreciated.
> > 
> > Thanks!
> > 
> > Regards,
> > Gregory Hicks
> > 
> >         gcc  -DIN_GCC   -g -O2   -o ../cc1chill parse.o actions.o except.o grant.o lang.o  tree.o lex.o decl.o typeck.o convert.o expr.o loop.o  tasking.o timing.o inout.o satisfy.o ch-version.o  `cat ../stamp-objlist`  `if [ xobstack.o != x ]; then echo 
> > ./alloca.o; else true; fi` `if [ x != x ]; then echo ../; else true; fi` -lld
> > ld: 0711-781 ERROR: TOC overflow. TOC size: 68040       Maximum size: 65536
> > collect2: ld returned 12 exit status
> You want to specify LDFLAGS=-Wl,-bbigtoc.
> If you're trying to use GNU ld, you can't do that with gcc 2.95.2.
> You will want to upgrade to 2.96 when it comes out.  The underlying
> problem is fixed in 2.96.
> -- 
> - Geoffrey Keating <>

More information about the Gcc-bugs mailing list