c/1524: problem with libgcc.so on sol 27, but not sol26

nneul@umr.edu nneul@umr.edu
Thu Dec 28 06:26:00 GMT 2000


>Number:         1524
>Category:       c
>Synopsis:       problem with libgcc.so on sol 27, but not sol26
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    unassigned
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Dec 28 06:26:03 PST 2000
>Closed-Date:
>Last-Modified:
>Originator:     nneul@umr.edu
>Release:        gcc version 2.97 20001221 (experimental) plus binutils 001221
>Organization:
>Environment:
solaris 2.7
>Description:
Unable to build stage3 libgcc.so?

./ld:libgcc.map: file format not recognized; treating as linker script
./ld:libgcc.map:1: parse error
collect2: ld returned 1 exit status
gmake[2]: *** [libgcc_s.so] Error 1
gmake[2]: Target `all' not remade because of errors.
gmake[2]: Leaving directory `/afs/umr.edu/software/egcs3/build.egcs/solaris27/gcc'
gmake[1]: *** [libgcc.a] Error 2

However, the interesting thing is - there is a libgcc.a built

The problem is - it causes a failure in the install target, so libgcc.a never gets
installed, rendering gcc useless.

I do not have this problem on Solaris 2.6, however, I don't see a libgcc.so on solaris 26.

>How-To-Repeat:

>Fix:

>Release-Note:
>Audit-Trail:
>Unformatted:


More information about the Gcc-bugs mailing list