Various build problems with gcc 2.95.2 on sparcv9-sun-solaris2.7 target...

Roland Mainz Roland.Mainz@informatik.med.uni-giessen.de
Mon Dec 6 14:37:00 GMT 1999


Alexandre Oliva wrote:

> On Dec  6, 1999, Roland Mainz <Roland.Mainz@informatik.med.uni-giessen.de> wrote:
>
> > - ... the sparcv9-gcc build looks for shared libs/objs in /usr/lib/ instead
> > of /usr/lib/sparcv9/
> > - ... "make bootstrap" fails because the bootstrap build passes a mix of
> > 32bit and 64bit objs to the linker
>
> Yup.  GCC 2.95.2 doesn't really support sparcv9.  The support is under
> development for the next major release.

Mhhh, code generation seems to work, but I didn't test it with complex apps yet. I'm
currently playing with Sun Workshop 6EA and compared it to my "configure - make -
make install" gcc-sparcv9 and the compiled projects produced the same results (e.g.
diff'ing the output)...

----


> > A sparcv9-gcc 2.95.2 C-only compiler can be build, but "make
> > bootstrap" fails
>
> It can't really be built, since bootstrap fails.  The GCC 2.95 series
> isn't suited for sparcv9 builds.  If you really want to, you may try
> development snapshots.

I'll wait for the upcoming version of gcc (date ?)... or is there any way to help
you ?

----

Bye,
Roland

--
  __ .  . __
 (o.\ \/ /.o) Roland.Mainz@informatik.med.uni-giessen.de
  \__\/\/__/  gisburn@informatik.med.uni-giessen.de
  /O /==\ O\  MPEG specialist, C&&JAVA&&Sun&&Unix programmer
 (;O/ \/ \O;) TEL +49 (0) 641/99-13193 FAX +49 (0) 641/99-41359





More information about the Gcc-bugs mailing list