Possible new testsuite test

Andrew Pollard andrew@odie.demon.co.uk
Sat Apr 24 10:30:00 GMT 1999

[ PS. This works in the egcs-19990422 I got from CVS, but it may be worth
adding to the testsuite... consider the code fragment public-domain :-) ]

Hi All,

[ egcs-19990418 snapshot, Linux-2.0.36-SMP, gnulibc1(libc-5.4.46),
  binutils- ]

 The following snippet of code causes a parse error with the egcs-19990418

struct A {
        struct B {};
        struct C;

struct A::C : public A::B {
        C() {}

% g++ -v
Reading specs from /usr/lib/gcc-lib/i586-pc-linux-gnulibc1/egcs-2.93.19/specs
gcc version egcs-2.93.19 19990418 (gcc2 ss-980929 experimental)
% g++ -c foo.cc
foo.cc:7: parse error before `;'

All the other versions I tried (gcc-, egcs-1.0.3, egcs-1.1.2,
egcs-19990422-cvs) worked.

Andrew Pollard, Auto Simulations Ltd. UK. | home: andrew@odie.demon.co.uk
2 Milbanke Court, Milbanke Way, Bracknell | work: Andrew_Pollard@autosim.com
Tel/Fax: (+44(0)1344) 426486x103 / 426615 | http://www.odie.demon.co.uk

More information about the Gcc-bugs mailing list