No subject

Jeffrey A Law
Sun Aug 2 00:27:00 GMT 1998

  In message < >you write:
  > I built both egcs-1.0.3a and egcs-19980727 using the same options;
  > binutils-2.9.1 pre-installed, and configured --with-gnu-as.  For egcs-19980  > 727
  > I specified no prefix, as I wanted it to install in the default /usr/local
  > which is where binutils-2.9.1 is installed.  for egcs-1.0.3a I specified a
  > subdirectory under /usr/local as I was attempting to set up for parallel
  > testsuite runs.

So for the snapshot, things should have worked and for egcs-1.0.3a
things should not have worked.

Is that consistent with what actually happened to you?

Note that a well placed symlink in the <prefix>/<configuration>/bin/as
to your gas binary can eliminate this problem.  I usually don't recommend
this though (since making the prefixes match is the better solution).

But for your case the symlink is probably the best thing to do for the
egcs-1.0.3a directory.

  > I ended up giving up on --with-gnu-as, hoping that won't
  > affect the regression testing.
Consistend use --with-gnu-as is important to regression testing on
the PA and some other platforms.

More information about the Gcc-bugs mailing list