Blitz++: internal compiler error

A.P.Manners andy@ideafix.litec.csic.es
Wed Apr 15 05:27:00 GMT 1998


Sir,

egcs fails with an internal compiler error when trying to build blitz++
The Blitz README states:

The Blitz++ library uses many new language features
which are not yet widely supported.  These platforms are
supported:

* egcs 1.0  (NOTE: there are currently problems with 1.0.1 and 1.0.2)
* KAI C++ (available on all major Unix platforms, and Linux too)
* Intel C++ (Windows'95, Windows NT, available as a Visual C++ drop-in)
  (see http://developer.intel.com/design/perftool/icl24/ )
* Cray C++ 3.0.0.0 (but performance is very poor)

Not working with 1.0.1 and 1.0.2 seems odd. I can forward more info. if
you would find it useful but have assumed you are aware of what is happening.


regards,

Andy Manners


Dr. A. P. Manners
CPS University of Zaragoza
Mecanica de Fluidos (LITEC)
Maria de Luna, 3
50015 Zaragoza
Spain
Tel: +34 976 761881
Fax: +34 976 761882
E-mail: andy@ideafix.litec.csic.es




More information about the Gcc-bugs mailing list