[PATCH 2/3] Factor out duplicate code in gimplify_scan_omp_clauses
Julian Brown
julian@codesourcery.com
Tue Dec 18 14:47:00 GMT 2018
On Sat, 10 Nov 2018 09:11:19 -0800
Julian Brown <julian@codesourcery.com> wrote:
> This patch, created while trying to figure out the open-coded
> linked-list handling in gimplify_scan_omp_clauses, factors out four
> somewhat repetitive portions of that function into two new outlined
> functions. This was done largely mechanically; the actual lines of
> executed code are more-or-less the same. That means the interfaces
> to the new functions is somewhat eccentric though, and could no doubt
> be improved. I've tried to add commentary to the best of my
> understanding, but suggestions for improvements are welcome!
>
> As a bonus, one apparent bug introduced during an earlier refactoring
> to use the polynomial types has been fixed (I think!): "known_eq (o1,
> 2)" should have been "known_eq (o1, o2)".
>
> Tested alongside other patches in this series and the async patches.
> OK?
Now the main part of the attach/detach support has been conditionally
accepted pending Thomas's approval (thanks!), is this prerequisite part
OK too?
Thanks,
Julian
More information about the Fortran
mailing list