[PATCH, Fortran] Four small DEC extensions

Steve Kargl sgk@troutmask.apl.washington.edu
Thu Oct 13 21:00:00 GMT 2016


On Thu, Oct 13, 2016 at 01:28:24PM -0700, Jerry DeLisle wrote:
> 
> Of the four in this patch, TYPE is the only one that I am
> uncomfortable with so maybe it should be behind -fdec, The
> other three seem minor to me, especially the LF, I dont think
> LF needs a flag.
> 
> I am sure others will chime in.

You know me; never afraid to offer an opinion.  :-)

I too am a little uncomfortable with TYPE.  Even though the
docs might indicate that this feature is for old moldy DEC
fortran code, I fully expect users to not read the docs.

> For clarity, so far we have:
> 
> flag_dec_intrinsic_ints
> flag_dec_structure
> flag_dec_static
> flag_dec_math
> flag_dec
> 
> and you were thinking about:
> 
> -fdec-feed] Treat form feed characters as whitespace.
> -fdec-type-print  Treat TYPE as an alias for PRINT where applicable.
> -fdec-loc-rval]
> -fdec-logical-xor
> 
> I would go with putting latter 3 just under -fdec and no flag
> for LF whitespace.

Hindsight is 20-20.  Not knowing how many more DEC extensions
are forthcoming, I think it may be better to hide everything
behind -fdec and add -fdec to -std=legacy.  If someone wants
-std=legacy with DEC extension, then one can use -fno-dec.
In other word, -fdec is an all-or-nothing option.  Again, 
opinions of others are welcomed.

-- 
Steve



More information about the Fortran mailing list