[RFC] unifying gfc_symbol and gfc_component

Fritz Reese fritzoreese@gmail.com
Mon Nov 14 17:35:00 GMT 2016


Resending as plaintext.

On Nov 14, 2016 06:43, "Janus Weil" <janus@gcc.gnu.org> wrote:
...
> Now that C++ is officially the implementation language of GCC (and
> thus gfortran), it is actually very simple to implement the above
> idea: One can just introduce a common base type (I'll call it
> gfc_entity for now, but that name is debatable of course), and make
> gfc_symbol and gfc_component inherit from that common base type.
>
> Attached is a patch which does that with just very few changes and
> compiles and regtests cleanly. This is just a first draft. One could
> certainly share more properties if one accepts slight naming changes
> (e.g. locus etc). Also the patch does not make any use of the new
> possibilities yet.
>
> Before I continue with that, I'd like to know what others think about
> this idea. Do you think this is useful, or could it cause any harm?
>
> Cheers,
> Janus

I for one am generally excited about taking advantage of new features.
I think the patch looks good and see no harm done. In fact I think
locus should be shared too.

---
Fritz Reese



More information about the Fortran mailing list