Ping! Re: [PATCH, Fortran] DEC extra integer intrinsics

Jerry DeLisle jvdelisle@charter.net
Tue Aug 2 22:30:00 GMT 2016


On 08/02/2016 02:31 PM, Fritz Reese wrote:
> On Tue, Aug 2, 2016 at 2:21 PM, Jerry DeLisle <jvdelisle@charter.net> wrote:
>> On 08/01/2016 11:47 AM, Fritz Reese wrote:
>>>
>>> https://gcc.gnu.org/ml/fortran/2016-07/msg00091.html
>>>
>>> On Mon, Jul 18, 2016 at 12:51 PM, Fritz Reese <fritzoreese@gmail.com>
>>> wrote:
>>>>
>>>> All,
>>>>
>>>> Attached is another extension patch introducing a new DEC
>>>> compatibility flag -fdec-intrinsic-ints. With this flag the compiler
>>>> recognizes the following variants for integer intrinsics which use a
>>>> B/I/J/K prefix (with byte/integer/long/quad kind parameters):
>>
>>
>> I have reviewed. Did you consider using make_alias to create these?
>>
>> Jerry
>
> I had not noticed make_alias before. That would considerably cut the
> size of the patch. I guess the difference would be the strictness on
> kind - which is probably usually automatically converted by GNU
> Fortran anyway. I'm okay with that change for clarity. Attached is
> what that patch would look like (bootstraps+passes all tests on
> x86_64-redhat-linux). If it's okay for trunk I'll commit it.
>

OK to commit.

Thanks,

Jerry



More information about the Fortran mailing list