[Fortran-CAF, Patch, committed] Cleanup in libcaf.h; declare caf_send

Tobias Burnus burnus@net-b.de
Fri Mar 14 20:59:00 GMT 2014


Hi all,

I have committed the attached patch to the Fortran-CAF branch. It paves 
the road to CAF sending support by declaring caf_send - and implementing 
it in libcaf_single.c (as memmove). Additionally, I cleaned up the 
library by handling the token in a better way (more readable - and 
permitting a cleaner implementation in the implementation part). 
Additionally, it includes some fixes to my recent branch patch.

The next step will be to add real sending support in the *compiler*, for 
which I have a draft patch. Adding send support to the library is a 
separate task and will be done by someone else.

Committed after building and regtesting on x86-64-gnu-linux as Rev. 208580.

Tobias



More information about the Fortran mailing list