[Patch, fortran] [62..66/66] inline sum and product: Inline sum.

Mikael Morin mikael.morin@sfr.fr
Thu Oct 27 23:36:00 GMT 2011


This is the purpose of all the serie of patches: inline sum and product.
Patches 62..65, possibly don't deserve a patch of their own, they just make
the changes in gfc_conv_intrinsic_arith easier to read.

The combined diff (context, ignoring indent changes) also attached here.

Patch 62: Change conditions.
Patch 63: Update argument handling.
Patch 64: Change loop usage.
Patch 65: Change gfc_se structs initializers.
Patch 66: Inline sum.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: pr43829-62..66.diff
Type: text/x-diff
Size: 13917 bytes
Desc: not available
URL: <http://gcc.gnu.org/pipermail/fortran/attachments/20111027/61b25014/attachment.bin>


More information about the Fortran mailing list