[Patch, Fortran] PR 48887 [4.7] Don't mark SELECT TYPE selector as allocatable/pointer
Tobias Burnus
burnus@net-b.de
Sat Dec 3 18:32:00 GMT 2011
Dear Paul,
Paul Richard Thomas wrote:
> Are you checking to see if the patches really are reviewed :-)
t
I am - but involuntarily. I am sure that I build and regtested - but
seemingly a different tree :-(
> The latter change gets rejected with my class array patch in place
> because I have:
I am really looking forward to have that patch in the trunk - it makes
patch writing and testing easier if one does not have two separate
trees, one clean with minor patches and one with your patch and
occasionally some on-top patches.
> This is OK:
>
> c->attr.pointer = attr->pointer || (attr->allocatable ? 0 : attr->dummy)
> || attr->select_type_temporary;
I have now used
|| (attr->dummy && !attr->allocatable)
instead of
|| (attr->allocatable ? 0 : attr->dummy)
which I found more readable.
I did also did a rebuild, regtested it and committed the patch as Rev.
181975.
Thanks for the careful review!
Tobias
More information about the Fortran
mailing list