[PATCH] split gfc_code.backend_decl into separate fields

Nathan Froyd froydnj@codesourcery.com
Sun Jun 27 20:01:00 GMT 2010


On Sun, Jun 27, 2010 at 09:41:53PM +0200, Tobias Burnus wrote:
> Nathan Froyd wrote:
> > gfc_code.backend_decl is an unusual animal: a field which is only ever
> > assigned a single, un-TREE_CHAIN'd TREE_LIST.  In the interest of
> > getting rid of TREE_LIST uses throughout the compiler, the patch below
> > splits backend_decl into the appropriate two fields.
> 
> OK. Thanks for the patch! I recently had a look at that code and found
> it awkward - thus also in terms of readability I like the patch.

Yes, my head hurts trying to keep TREE_PURPOSE and TREE_VALUE straight
when translating away from TREE_LIST. :)

Thanks for the review.  Committed as r161473.

-Nathan



More information about the Fortran mailing list