[Patch, libgfortran] Some janitorial work

Paul Richard Thomas paul.richard.thomas@gmail.com
Wed Apr 8 08:56:00 GMT 2009


Janne,

Many thanks for that!  You remind of the advert for a well none
management consultancy that showed two pictures of a janitor holding
his brush, posing in front of the space shuttle inside the assembly
building.  One has the caption "janitor with brush" and the other
"janitor with space shuttle launch tool":-)

OK for trunk.

Paul

On Tue, Apr 7, 2009 at 11:32 PM, Janne Blomqvist
<blomqvist.janne@gmail.com> wrote:
> Hi,
>
> the attached patch does a little bit of janitorial work in libgfortran.
>
> Regtested on i686-pc-linux-gnu, Ok for trunk?
>
> --
> Janne Blomqvist
>
> 2009-04-08  Janne Blomqvist  <jb@gcc.gnu.org>
>
>        * runtime/string.c (compare0): Use gfc_charlen_type.
>        * runtime/error.c (gfc_itoa): Move to io/write.c
>        (xtoa): Rename to gfc_xtoa.
>        * runtime/backtrace.c (show_backtrace): Call gfc_xtoa.
>        * intrinsics/cshift0.c (cshift0): Use index_type for shift arg.
>        * intrinsics/date_and_time.c (date_and_time): Use index_type.
>        (itime_i4): Likewise.
>        (itime_i8): Likewise.
>        (idate_i4): Likewise.
>        (idate_i8): Likewise.
>        (gmtime_i4): Likewise.
>        (gmtime_i8): Likewise.
>        (ltime_i4): Likewise.
>        (ltime_i8): Likewise.
>        * libgfortran.h (gfc_itoa): Remove prototype.
>        (xtoa): Rename prototype to gfc_xtoa.
>        * io/list_read.c (nml_read_obj): Use size_t for string length.
>        * io/transfer.c (read_block_direct): Change nbytes arg from
>        pointer to value.
>        (unformatted_read): Minor cleanup, call read_block_directly properly.
>        (skip_record): Use ssize_t.
>        (next_record_w_unf): Avoid stell() call by calling sseek with SEEK_CUR.
>        (iolength_transfer): Make sure to multiply before cast.
>        * io/intrinsics.c (fgetc): Remove unnecessary variable.
>        * io/format.c (format_hash): Use gfc_charlen_type.
>        * io/write.c (itoa): Move from runtime/error.c:gfc_itoa, rename,
>        make static.
>        (write_i): Call itoa.
>        (write_z): Likewise.
>        (write_integer): Likewise.
>        (nml_write_obj): Type cleanup, don't call strlen in loop.
>
>



-- 
The knack of flying is learning how to throw yourself at the ground and miss.
       --Hitchhikers Guide to the Galaxy



More information about the Fortran mailing list