[Patch, Fortran] Follow-up to used-before-typed patch

Tobias Burnus burnus@net-b.de
Fri Aug 22 10:02:00 GMT 2008


Hi Daniel,

Daniel Kraft wrote:
> Regarding the in_prefix and parser-state, I've tried to do this but 
> got two failures for function_kind_2.f90 and function_type_1.f90 
> (IIRC) as the logic handling those is bailing out because of the new 
> parser-state.  I'm not sure if this is really a good idea; maybe I 
> should just rename in_prefix to gfc_matching_prefix, for instance, to 
> get consistent with e.g. gfc_matching_function?
I was also rethinking it and maybe using something like 
gfc_matching_prefix is indeed better. I also think one could move it 
from gfortran.h to match.h. (I'm sure there are other extern variables 
in gfortran.h which could be moved as well.)

> Another idea would be to construct some sort of global flag-structure 
> combining gfc_matching_function, gfc_matching_prefix and possibly 
> others like this.   Any comments regarding this part?
Actually, that was what I initially understood from your proposal 
(misreading what you meant). That would be an option - I'm not 100% sure 
what one would gain and what one would loose in terms of readability.

Tobias



More information about the Fortran mailing list