[PATCH, Fortran] preparing procedure pointers
Janus Weil
jaydub66@googlemail.com
Mon Apr 14 22:10:00 GMT 2008
2008/4/5, Janus Weil <jaydub66@googlemail.com>:
> Btw, is it possible that there is a documentation error in gfotran.h?
> In the declaration of gfc_symbol I found the following:
>
> /* The interface member points to the formal argument list if the
> symbol is a function or subroutine name. If the symbol is a
> generic name, the generic member points to the list of
> interfaces. */
>
> I think this mistakes the 'interface' member with the 'formal' member,
> right? After all it cannot refer to the 'interface' member, which I
> introduced last year, and which I want to move to gfc_typespec with
> this patch I just sent. This piece of documentation clearly does not
> come from me.
Could anyone please confirm that this is an error? I'm almost sure it
is, but it would be nice if someone could double-check it. The comment
quoted above can be found in gfortran.h, lines 982-985, in the typedef
of 'gfc_symbol'. It looks like this comment has been in gfortran from
the start. 'svn blame' tells me it has been committed by dnovillo in
May 2004 as rev. 81764, which merged the tree-ssa branch into mainline
and introduced the gfortran front end into GCC. It seems that this was
inherited from g95, and indeed it also can be found in recent g95
sources, where it doesn't make any more sense than in gfortran.
g95_symbol does not even have a member called 'interface' ...
Cheers,
Janus (who hopes desperately someone can resolve his confusion)
More information about the Fortran
mailing list