[Patch, Fortran] PR34262 - Fix MVBITS with arrays

Paul Thomas paulthomas2@wanadoo.fr
Wed Nov 28 23:29:00 GMT 2007


Tobias Burnus wrote:
>
> I find my method rather clumsy. Has someone a better idea? If not, OK
> for the trunk?
>
>
>   
Your patch is OK :-)

However, is the attached not more elegant?  The extension to all the 
other intrinsics is done by setting CLASS_ELEMENTAL in intrinsic.c and 
by adding the extra argument to the calls to 
gfc_get_intrinsic_sub_symbol, for the generic name.

Cheers and thanks

Paul



More information about the Fortran mailing list