[patch, PR 32731] fix pack and unpack for kind=1 and kind=2 mask
FX Coudert
fxcoudert@gmail.com
Sat Jul 14 12:24:00 GMT 2007
> The reason why I hard-coded the magic number 4 in a few places is
> because we only have kind=4 masks for scalar masks, and the
> GFC_LOGICAL
> conversion trick is also hardcoded in the library.
That's reason enough for me!
> I also would have
> felt silly defining a GFC_DEFAULT_DEFAULT_LOGICAL_KIND, but I'm open
> to suggestions.
No, I really think we should do that in the future. At some point,
the compiler and library should become completely independent of what
actual logical, integer and real kinds are available.
But, for now, we have more important bugs to fix!
> 2007-07-13 Thomas Koenig <tkoenig@gcc.gnu.org>
>
> PR libfortran/32731
> * iresolve.c(gfc_resolve_pack): A scalar mask has
> to be kind=4, an array mask with kind<4 is converted
> to gfc_default_logical_kind automatically.
> (gfc_resolve_unpack): Convert mask to gfc_default_lotical_kind
> if it has a kind<4.
OK
More information about the Fortran
mailing list