[Patch, fortran] PR30284 and PR30626 - ICEs with internal units

Paul Thomas paulthomas2@wanadoo.fr
Thu Feb 1 22:44:00 GMT 2007


:ADDPATCH fortran:

These two PRs are effectively identical and are fixed by the same patch.

The problem is that substring or components references of arrays result 
in element sizes that are smaller than the stride in bytes.  This is 
fixed by using the same temporary builder that fixed a similar problem 
in gfc_conv_function_call.  A temporary is created that is copied to and 
used as the internal unit for READ or is used and copied back from for 
WRITE.  The testcases are the reporter's.

Note that I am perfectly prepared to change the names of 
gfc_conv_aliased_arg and is_aliased_array, if only somebody would tell 
me what they should be called :-)

Bootrtrapped and regtested on amd64/Cygwin_NT - OK for trunk and a week 
or two later for 4.2?

Paul
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: Change.Logs
URL: <http://gcc.gnu.org/pipermail/fortran/attachments/20070201/406838ef/attachment.ksh>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: pr30284.diff
Type: text/x-patch
Size: 10668 bytes
Desc: not available
URL: <http://gcc.gnu.org/pipermail/fortran/attachments/20070201/406838ef/attachment.bin>


More information about the Fortran mailing list