[patch,fortran] Allow namelist with internal file (PR 28224)
Paul Thomas
paulthomas2@wanadoo.fr
Sat Oct 28 23:56:00 GMT 2006
Tobias Burnus wrote:
> Hi,
>
> Paul Thomas schrieb:
>
>> Might it not be better to use -std=f95 for this test....
>>
>>> * gfortran.dg/namelist_internal.f90: New namelist test.
>>> * gfortran.dg/namelist_internal2.f90: New namelist test.
>>>
>> ...and to drop this latter?
>>
> Well, the first test test whether internal file read/write of namelists
> works.
> The second test tests whether it is still forbidden for -std=f95.
>
The latter means the last one...
> I can drop either test, but I cannot simply change -std=f2003 to
> -std=f95 in the first test; doing all the modifications needed, I will
> end up with the second test.
>
Test the new feature but try to keep the old all inclusive test is what
I was after.
Paul
> That is anyhow the question: How much should one test? Only a minimal
> set, which will get easily broken or also more extensively the behaviour
> of a function, even if it is unlikely that a regression occurs?
> The former prevents bloating, the latter reduces the chance of more
> unlikely regressions.
>
> In this regard, shall I check in namelist_internal.f90 or
> namelist_internal2.f90 or both?
> (If only namelist_internal2.f90, I will rename it to namelist_internal.f90.)
>
> Tobias
>
>
>
More information about the Fortran
mailing list