Possible fix to PR 14059
Paul Brook
paul@codesourcery.com
Sun May 16 23:18:00 GMT 2004
On Sunday 16 May 2004 21:37, Steve Kargl wrote:
> Gang,
>
> Below is a patch that may be a fix for 14059.
Please supply ChangeLog entries with patches.
gfc_range_check should be renamed, and the comment updated to indicate that it
may change the value of the expression.
> Should gfortran issue a warning for the UNDERFLOW?
If we bother checking for underflow, we may as well allow issuing of a
warning.
if (rc == ARITH_UNDERFLOW)
{
rc = ARITH_OK;
*resultp = result;
}
else if (rc != ARITH_OK)
Would be better written as
if (rc != ARITH_OK && rc != ARITH_UNDERFLOW)
Either way, I think this logic would be better moved into gfc_range_check.
What about all the other places that use gfc_check_range/gfc_check_real_range,
should they still issue errors? For example, ifort accepts the following
without complaint:
real :: r = 1.0e-99
Where TINY(r) == 1.1754943E-38
Paul
More information about the Fortran
mailing list