[gfortran] Scanner rewrite, fix for PR13702

Joseph S. Myers jsm@polyomino.org.uk
Tue May 11 19:48:00 GMT 2004


On Tue, 11 May 2004, Eric Christopher wrote:

> > I changed that deliberately. Naming a variable l just doesn't seem to be 
> > a good idea, even if it's used in only one place. Or was that a 1 there?
> 
> FWIW I agree. Names should at least be recognizable.

And (as Kenner keeps reiterating) functions should all have comments
explaining what they do and what their parameters and return values mean.
The context in this patch shows that it was a pre-existing condition that
this function lacks such a comment.  Hopefully gfortran can get such
comments while people still remember the intent from when the functions
were written rather than trying to reverse engineer much later.

-- 
Joseph S. Myers
jsm@polyomino.org.uk



More information about the Fortran mailing list