This is the mail archive of the
mailing list for the libstdc++ project.
Re: Names of header include guards
On Tue, Jul 22, 2003 at 12:12:23AM +0200, Gabriel Dos Reis wrote:
> Nathan Myers <firstname.lastname@example.org> writes:
> | In fact, it would be a Good Thing to have a suffix or prefix on
> | the include guards that looks more or less random, to make it really
> | unlikely to collide with platform names. I'd welcome a patch that put
> | suffixes like "_EXDRJVZQIO" on all our header guard names.
> What I do not understand is why we removed the _GLIBPCPP prefix (or
> _CPP_BITS) instead of replacing it just with _GLIBCXX_. what was the
I agree. "cvs annotate" shows that change occurring on July 5.
I don't recall any discussion of such a proposal.