This is the mail archive of the gcc@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Unifying the GCC Debugging Interface


On Tue, Nov 20, 2012 at 11:19:41AM -0800, Lawrence Crowl wrote:
> On 11/19/12, Diego Novillo <dnovillo@google.com> wrote:
> > On Nov 19, 2012 Michael Matz <matz@suse.de> wrote:
> > > So, yes, the larger layouting should be determined by name of the
> > > dump function.  A flag argument might look nice from an interface
> > > design perspective, but it's harder to use in the debugger.
> >
> > As long as all these different objects share the same data
> > structure, we will need to have different named entry points.
> > Ideally they would all respond to 'dump(t)' and overloading will
> > figure it out automatically.  For now, we'll need dump_function,
> > dump_tree, dump_generic, and we may need a few more.
> 
> Diego and I talked about this a bit more, and would like to explore
> a set of dump names that distinguish between dumping the head of
> an item and its body.  In essence, the former asks for the function
> declaration, the latter its definition.
> 
> Comments?

Well, it sounds a bit too artificial to me, but I can live with
remembering that dump_head is actually dump_generic and dump_body is
dump_tree... or would it be dump_function?

I still think that (as a first step) if you can reduce the number of
dump function names only somewhat and make their parameters consistent
in the process, it will help a lot (and will be quite some work).  If
you then want to continue unifying the names more, you'll be able to
do it easily and immediately see what makes sense and what does not.

Martin


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]