This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH, libphobos] Committed merge with upstream druntime 5bb8ce19


On 21.08.19 10:02, Iain Buclaw wrote:
> Hi,
> 
> This patch merges the libdruntime library with upstream druntime 5bb8ce19.
> 
> Synchronizes extern(C) bindings with the latest release, mostly this
> is just Musl target support.
> 
> Bootstrapped and regression tested on x86_64-linux-gnu and x86_64-linux-musl.
> 
> Committed to trunk as r274773.

Does the change the ABI?  Asking, because apparently the out-of-tree libgphobos
for GCC 8, and the one in GCC 9 don't seem to be ABI compatible.

Matthias


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]