This is the mail archive of the
mailing list for the GCC project.
Re: [AArch64] Use arrays and loops rather than numbered variables in aarch64_operands_adjust_ok_for_ldpstp [1/2]
- From: Jackson Woodruff <jackson dot woodruff at arm dot com>
- To: Kyrill Tkachov <kyrylo dot tkachov at foss dot arm dot com>, "gcc-patches at gcc dot gnu dot org" <gcc-patches at gcc dot gnu dot org>
- Cc: James Greenhalgh <James dot Greenhalgh at arm dot com>, Marcus Shawcroft <Marcus dot Shawcroft at arm dot com>, Richard Earnshaw <Richard dot Earnshaw at arm dot com>, nd <nd at arm dot com>, "christophe dot lyon at linaro dot org" <christophe dot lyon at linaro dot org>
- Date: Wed, 11 Jul 2018 11:28:30 +0100
- Subject: Re: [AArch64] Use arrays and loops rather than numbered variables in aarch64_operands_adjust_ok_for_ldpstp [1/2]
- References: <email@example.com> <5B44828C.firstname.lastname@example.org>
On 07/10/2018 10:55 AM, Kyrill Tkachov wrote:
On 10/07/18 09:37, Jackson Woodruff wrote:
This patch removes some duplicated code. Since this method deals with
four loads or stores, there is a lot of duplicated code that can easily
be replaced with smaller loops.
Regtest and bootstrap OK.
OK for trunk?
This looks like a good cleanup. There are no functional changes, right?
Yes, there are no functional changes in this patch.
Looks good to me, but you'll need approval from a maintainer.
2018-06-28 Jackson Woodruff <email@example.com>
Use arrays instead of numbered variables.