This is the mail archive of the
mailing list for the GCC project.
Re: [C++ PATCH] conversion operator names
On 06/30/2017 03:11 PM, Jason Merrill wrote:
On Fri, Jun 30, 2017 at 2:48 PM, Nathan Sidwell <firstname.lastname@example.org> wrote:
We used to give conversion operatos type-specific mangled names. Now we
just number them 'operator $N' for N in [1,...]. As such
mangle_convop_name_for_type is misnamed and has no place in mangle.c
Hmm, wouldn't actual mangling make more sense, so that it's consistent
While that would work, I have a different and simpler plan in mind.