This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [C++ PATCH] conversion operator names


On Fri, Jun 30, 2017 at 2:48 PM, Nathan Sidwell <nathan@acm.org> wrote:
> We used to give conversion operatos type-specific mangled names.  Now we
> just number them 'operator $N' for N in [1,...].  As such
> mangle_convop_name_for_type is misnamed and has no place in mangle.c

Hmm, wouldn't actual mangling make more sense, so that it's consistent
between compilations?

Jason


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]